×

[PR]この広告は3ヶ月以上更新がないため表示されています。
ホームページを更新後24時間以内に表示されなくなります。

Tiny3D マニュアル

iPhone/iPod touch用3Dエディタ&ビューアTiny3Dバージョン3.0のマニュアル

English top page

目次

起動
3D表示
画面下に表示されるタブの役割
3Dエディタ
基本図形(エレメント)
各基本図形の説明
マクロリスト
ツール
バージョンの確認方法
補足情報


起動

アイコン

ホーム画面に作成されるアイコンをタップすると起動します。起動後データの読み込みを行い、読み込みが終了すると3D表示画面になります。


3D表示

描画完了

全画面で3Dオブジェクトを表示します。基本操作はタッチパネルで行います。初期設定では画面上方に操作ガイドが表示されます。


操作方法

3D表示を終了し3Dエディタ画面へ:画面をタップ
オブジェクトの移動:2本指でのドラッグ
オブジェクトの回転:ドラッグ
ズームイン/アウト:ピンチオープン/クローズ
表示リセット:デバイスを軽く振る


3D表示画面の軸の定義

自動回転を行わない状態での表示開始時点での軸とその正方向の定義は以下のようになります。座標系は右手系になっています。

X軸

画面の左右方向を示す軸です。右方向が正です。デフォルト設定で画面中央が0、およそ-6から6くらいの範囲が表示されます。

Y軸

画面の上下方向を示す軸です。上方向が正です。デフォルト設定で画面中央が0、およそ-9から9くらいの範囲が表示されます。

Z軸

画面の奥行き方向を示す軸です。手前の方向が正です。

なおオブジェクト、パート、エレメントの各リスト編集画面で設定できる回転は、必ずX軸、Y軸、Z軸の順番で回転させます。 回転の方向は各軸の正から負の方向を見た場合で、反時計回りの方向が正になります。


画面下に表示されるタブの役割

3D表示

3Dオブジェクトを表示します。


3Dエディタ

3Dオブジェクトデータを編集します。

マクロ

位置と色を素早く入力するためのマクロを作成・編集します。

ツール

オブジェクトなどのコピー・移動やデータの入出力、3D表示画面の設定を行います。

操作ガイド

操作ガイドを表示します。


3Dエディタ

オブジェクトリストでの編集項目
パートリストでの編集項目
エレメントリストでの編集項目
エレメント詳細設定画面
エレメント詳細設定:各頂点設定


通常モードでの操作

オブジェクト

下層のリストへ移動:リスト項目のタップ
上層のリストへ移動:バックボタンのタップ
3Dエディタ編集モードへ:編集ボタンのタップ


編集モードでの操作

オブジェクト編集

表示/非表示の切替:リスト項目のタップ
項目の追加:+ボタンのタップ
項目の削除:-ボタンのタップ後、削除ボタンをタップ
項目の編集:>ボタンのタップ
項目の移動:=のドラッグ
3Dエディタ通常モードへ:完了ボタンのタップ


オブジェクトリストでの編集項目

オブジェクト編集

表示スイッチ

表示/非表示の切り替えスイッチです。非表示にすると下層にあるパートやエレメントも3D表示画面で見えなくなります。 非表示になっている場合、リストでオブジェクト名が灰色で表示されます。

名前

リストに表示される名称です。オブジェクトの名前はアップロード時のファイル名にもなります。

中央座標

オブジェクトの中央座標です。標準設定は全ての軸で0です。

回転角度

オブジェクトの回転角度です。標準設定は全ての軸で0です。

拡大倍率

オブジェクトの表示倍率です。1でそのままの大きさになります。


パートリストでの編集項目

パート編集

表示スイッチ

表示/非表示の切り替えスイッチです。非表示にすると下層にあるエレメントも3D表示画面で見えなくなります。 非表示になっている場合、リストでパート名が灰色で表示されます。

名前

リストに表示される名称です。

中央座標

オブジェクトの中央座標です。標準設定は全ての軸で0です。

回転角度

オブジェクトの回転角度です。標準設定は全ての軸で0です。

表示倍率

オブジェクトの表示倍率です。1でそのままの大きさになります。


エレメントリストでの編集項目

エレメント編集

表示スイッチ

表示/非表示の切り替えスイッチです。非表示にすると3D表示画面で見えなくなります。 非表示になっている場合、リストでエレメント名が灰色で表示されます。

名前

リストに表示される名称です。

中央座標

オブジェクトの中央座標です。標準設定は全ての軸で0です。

回転角度

オブジェクトの回転角度です。標準設定は全ての軸で0です。

表示倍率

オブジェクトの表示倍率です。1でそのままの大きさになります。

法線の反転

標準設定 法線反転

バージョン1.6.0でライティング機能を追加するため、それに合わせて追加したオプションです。 例えば半球の場合、通常は外側が外面になりますので、法線ベクトルは中から外の方向に向きます。 しかし底面をオフにして御椀の内側の面として用いた場合、法線ベクトルは外から内の方向に向かなければなりません。 このような場合で法線の方向を反転したいとき、このスイッチをオンにすると法線の方向が逆向きになります。 上のスクリーンショットでは、左が反転オフ、右が反転オンの状態です。 フロントライトに反応して反射をする面が切り替わっているのが確認できます。

タイプ

エレメントの形態です。新規エレメントで変更できます。エレメントリスト画面に戻った後は変更できなくなります。


エレメント詳細設定画面

エレメント詳細タイプA エレメント詳細タイプB
エレメント詳細タイプB編集 エレメント頂点

画面の左上にそのエレメントで設定に用いる頂点が表示されます。各頂点の数字は右側のリストと対応しています。 バージョン1.5.0以上ではエレメント詳細設定画面はタイプA、タイプBの2種類があります。 バージョン1.5.0以上で追加した連続線、連続三角形、三角扇がタイプB、それ以外がタイプAです。 上のスクリーンショットの左側がタイプA、右側がタイプBの画面です。 タイプAでは画面の左下には塗りおよび壁面の表示スイッチがあります。画面右側には各頂点の設定項目のリストが表示されます。 タイプBでは画面の右上にループ、塗り、線の太さの項目が表示され、画面下部に各頂点の設定項目のリストが表示されます。

塗りスイッチ

立体の各面を塗りつぶします。オフにするとワイヤーフレーム表示になります。ワイヤーフレーム表示でも色の設定は有効です。 線の太さは1ピクセルの固定になります。照明をオンにしてもワイヤーフレーム表示の場合は色の設定は有効になります。

壁面表示スイッチ

上面

オブジェクトの上面の表示/非表示を切り替えます。

側面

円錐・円柱・半球・球の各オブジェクトの角度指定が360度より小さい場合、オンにすると側面に壁を表示します。

底面

オブジェクトの底面の表示/非表示を切り替えます。

ループ

バージョン1.5.0で追加した3種の基本図形に対してバージョン1.6.0で追加されたオプションです。 連続線と連続三角形の場合、オンにすると一番最後の頂点と一番目の頂点がつながります。 三角扇の場合は一番目の頂点は扇の中心なので、一番最後の頂点と二番目の頂点でつながります。

点の大きさ

ピクセル単位で指定します。

線の太さ

ピクセル単位で指定します。

辺1長

1辺目(X軸上にある辺)の長さを指定します。

辺2長

2辺目の長さを指定します。

角度(辺)

2辺の交わる角度を指定します。0~360度の範囲で指定します。90度の場合にZ軸上になります。

半径X

X軸方向の半径を指定します。リングの場合円2つの半径(X1、X2)をそれぞれ指定します。

半径Y

Y軸方向の半径を指定します。

半径Z

Z軸方向の半径を指定します。リングの場合円2つの半径(Z1、Z2)をそれぞれ指定します。

角度

底面の角度をX軸の正の方向を0度とする時計回りで、0~360度の範囲で指定します。

分割数

表示する物体の精度を決定します。1以上の数値を指定します。


エレメント詳細設定:各頂点設定

頂点名

頂点の名前を設定します。

位置/色設定マクロスイッチ

位置マクロ選択 色マクロ選択
位置情報直接入力 色情報直接入力

設定にマクロを使用する場合はオンにします。スイッチがオンになるとマクロリストが開くので、リストから連動させるマクロを選びます。 スイッチがオフになった場合には直接入力画面が開くので、値を入力してセーブします。マクロの選択を行わずバックボタンをタップした場合と、 直接入力画面でキャンセルをタップした場合には、スイッチは操作前の状態に戻ります。 上のスクリーンショットの左2つがマクロリストで、右2つが直接入力画面です。 なお、次項で説明しますがバージョン2.0以降では、色の直接入力画面にACIパレットを開くボタンが追加されています。


位置/色情報

ACI入力前 ACIパレット ACI入力後

各マクロスイッチがオンの場合、タップするとマクロリストが開き、マクロを選択できます。オフの場合はタップすると位置情報を直接入力できます。 直接入力画面にある-ボタンをタップすると、現在の設定値をマクロリストへ登録できます。バージョン1.6.0以降で搭載される照明をオンにしていると、 塗りスイッチがオフになっていない場合、設定されてる色情報は点、線、連続線以外では全て無視されます。 バージョン2.0より直接入力画面にACIパレットを開くボタンが追加されました。場所は名前の入力フィールドの左側です。パレットは上下にスクロールします。 変更したい色をダブルタップするか、右上の完了ボタンを押すとそのインデックスを選択し、元の数値入力画面へと戻ります。 なお、アルファ値は変更されません。 ACIの詳細は補足情報のACI(AutoCADカラーインデックス)についてを参照してください。


基本図形(エレメント)

エレメント選択

物体の製作に使う基本図形(エレメントと呼んでいます)を紹介します。現在のバージョン2.0には以下に挙げる19種類の基本図形があります。



三角形
三角錐(タイプA)
四角形(平行四辺形)
楕円
円外部
リング
三角錐(タイプB)
四角錘
円錐
三角柱
四角柱
円柱
半球

連続線(折れ線)
連続三角形
三角扇

それぞれの基本図形について説明する前に、まず基本的な約束事を説明します。
なおこれから説明する基本事項はバージョンアップにより変更される可能性もあります。


基本事項の説明

規定値の状態のままだと3D表示画面の座標系からエレメントの座標系までの全てが同一の座標系になりますが、 各階層ごとに基本図形を平行移動・回転させたり、拡大・縮小を行うことが出来ます。それらの設定値を変更すると、座標系は3D表示のものとは異なるものになります。 例えばオブジェクトで2倍に拡大させ、パートでも3倍に拡大、さらにエレメントで4倍に拡大したとすると、エレメントの設定では1の長さのものが3D表示の座標系では24(=2×3×6)に拡大されます。 同様の変化は平行移動や回転でも起こります。以下で座標を示す場合には、全て設定値が規定値の状態でエレメントが所属しているローカルな座標系における座標を示すものとし、 ()内の数値は順番にx座標、y座標およびz座標の値を示すものとします。


設定のタイプ

基本図形の設定方法は3種類のタイプに分けられます。

直接座標指定タイプ

頂点の位置を直接指定します。点、線、三角形、三角錐(タイプA)、連続線、連続三角形、三角扇が該当します。

間接座標指定タイプ

辺の長さや円の半径などを指定します。位置の基準は原点(0,0,0)になります。2辺を指定する場合、1つ目の辺はX軸上にあります。2つ目の辺は規定値(90度)の場合にZ軸上にあります。 2つ目の辺は角度を変更することによりZ軸以外の方向へ変更できます。半径の指定はそれぞれの軸方向ごとに変更できます。 四角形(平行四辺形)、楕円、円外部、リング、半球、球が該当します。

混合タイプ

底面部の設定は間接座標指定でますが、底面以外の一頂点を直接座標で指定します。三角錐(タイプB)、四角錘、円錐、三角柱、四角柱、円柱が該当します。


円や球の分割数設定

分割数を増やすほどより綺麗な円や球が描かれます。ただしより多くの頂点が作られるため、描画処理の負担は増えます。 球や半球の場合には、Y軸方向の90度あたりの分割数を決定します。XZ平面側の分割数はそれを元に自動的に決定されます。 例えば角度が360度の場合には、XZ平面側の分割数は設定値の4倍になります。


色の設定

色は各エレメントの詳細設定画面で左上に表示される図の点の部分だけ設定できます。それ以外の部分は設定できません。 またバージョン1.6.0以降で搭載される照明をオンにしていると、 塗りスイッチがオンの場合には設定されてる色情報は点、線、連続線以外で無視されます。


法線の方向

三角形、連続三角形、三角扇は左上のガイドの位置関係で頂点を配置した場合に、Z軸の手前が法線ベクトルの向きになります。楕円などXZ平面上に作成されるものは法線がY軸の正方向になります。 三角錘など立体物はそれぞれ外側の面が表面となるように法線が作成されます。なお各頂点の法線は自動で作成されるため、個別の数値設定は出来ません。 ただしエレメントリストの編集項目である法線の反転スイッチでエレメントの法線を全て反対方向に変えることは出来ます。 意図する方向でフロントライトの反射が起きない場合には、このスイッチで法線ベクトルを反転させてください。

前提となる基本的な約束事は以上です。次にそれぞれの基本図形について説明します。


各基本図形の説明

点

点です。設定により画面上での点の大きさ(注:座標系の単位ではなく画面のピクセル単位です)と位置、色を任意に変更できます。 バージョン1.5.0まででは位置マクロが存在する場合、作成時には1個目の位置マクロの値が入ります。 バージョン1.6.0以上では位置マクロの状態と関係なく、原点(0,0,0)に大きさ2の点が表示されます。

線

線です。設定により画面上での線の太さ(注:座標系の単位ではなく画面のピクセル単位です)と2つの頂点の位置、色を任意に変更できます。 バージョン1.5.0まででは位置マクロが存在する場合、作成時には2点とも1個目のマクロの値が入るため、3D表示には何も表示されません。 頂点の位置を位置マクロリストから選択するか、マクロとの連動を切って個別に値を編集し、点の位置が重ならないように変更すると表示されます。 バージョン1.6.0以上では位置マクロの状態と関係なく、(0,0,0)と(1,2,0)を頂点とする太さ2の線が表示されます。

三角形

三角形

三角形です。設定により3つの頂点の位置、色を任意に変更できます。オプションで塗りつぶしの有無を選べます。 バージョン1.5.0まででは位置マクロが存在する場合、作成時には3点とも1個目のマクロの値が入るため、3D表示には何も表示されません。 頂点の位置を位置マクロリストから選択するか、マクロとの連動を切って個別に値を編集し、点の位置が重ならないように変更すると表示されます。 バージョン1.6.0以上では位置マクロの状態と関係なく、(0,0,0)、(1,2,0)、(2,0,0)を頂点とする三角形が表示されます。

三角錐(タイプA)

三角錐(タイプA)

三角錘です。設定により4つの頂点の位置、色を任意に変更できます。オプションで塗りつぶしの有無を選べます。 バージョン1.5.0まででは位置マクロが存在する場合、作成時には4点とも1個目のマクロの値が入るため、3D表示には何も表示されません。 頂点の位置を位置マクロリストから選択するか、マクロとの連動を切って個別に値を編集し、点の位置が重ならないように変更すると表示されます。 バージョン1.6.0以上では位置マクロの状態と関係なく、(1,2,1)、(0,0,0)、(2,0,0)、(1,0,2)を頂点とする三角錐が表示されます。

四角形(平行四辺形)

四角形(平行四辺形)

四角形です。設定により2辺の長さとそのなす角、4つの頂点の色を任意に変更できます。オプションで塗りつぶしの有無を選べます。 基本設定の状態では、XZ平面上に原点を1つの頂点とし、2辺がX軸およびZ軸上にあり、各辺の長さが1の正方形が作成されます。 そこからエレメントリスト側の編集で移動や回転を行って空間内に配置します。

楕円

楕円

楕円です。XZ平面上に原点(0,0,0)を中心とし設定した半径の円を描きます。X軸およびZ軸方向で指定した半径で、指定した角度までの円が描かれます。 角度はX軸の正の方向を0度として、Y軸の正の側から見て時計方向に増加します。左上のガイドに表示される5点の色が変更できます。 分割数を大きくするとより綺麗な円になりますが、その分描画処理の負担は増えます。オプションで塗りつぶしの有無を選べます。 基本設定の状態では、XZ平面上に原点を中心とする半径1の円が作成されます。 そこからエレメントリスト側の編集で移動や回転を行って空間内に配置します。

円外部

円外部

バージョン1.2.0で追加されました。四角形とそれに内接する円にはさまれる部分を描きます。要するに円と四角形の間の穴埋めを行う時に使います。円の設定は上の円と同じです。 角度はX軸の正の方向を0度として、Y軸の正の側から見て時計方向に増加します。左上のガイドに表示される8点の色が変更できます。 分割数を大きくするとより綺麗な円になりますが、その分描画処理の負担は増えます。オプションで塗りつぶしの有無を選べます。 基本設定の状態では、XZ平面上に原点(0,0,0)を中心とする半径1の円と、その外部に接触する各辺の長さ2の正方形にはさまれる部分が作成されます。 そこからエレメントリスト側の編集で移動や回転を行って空間内に配置します。

リング

リング

バージョン1.2.0で追加されました。2つの円ではさまれる部分を描きます。半径はX軸およびZ軸方向でそれぞれ2つ設定します。 角度はX軸の正の方向を0度として、Y軸の正の側から見て時計方向に増加します。左上のガイドに表示される8点の色が変更できます。 分割数を大きくするとより綺麗な円になりますが、その分描画処理の負担は増えます。オプションで塗りつぶしの有無を選べます。 基本設定の状態では、XZ平面上に原点(0,0,0)を中心に外側が半径1、内側が半径0.5の円にはさまれた部分にリングが作成されます。 そこからエレメントリスト側の編集で移動や回転を行って空間内に配置します。

三角錐(タイプB)

三角錐(タイプB)

三角錐です。タイプAとは異なり底面と1頂点の位置を用いて設定します。左上のガイドに表示される4点の色が変更できます。 底面の2辺の設定は四角形の原点を含む2辺と同様です。オプションで塗りつぶしの有無と底面の表示/非表示を選べます。 基本設定の状態では、XZ平面上にある原点を1つの頂点とする各辺の長さが1の直角2等辺三角形を底面とし、(0,1,0)を残りの頂点とする三角錐が作成されます。 そこからエレメントリスト側の編集で移動や回転を行って空間内に配置します。

四角錘

四角錘

四角錘です。底面設定は四角形と同様です。それに1頂点を追加して四角錘にします。左上のガイドに表示される5点の色が変更できます。 オプションで塗りつぶしの有無と底面の表示/非表示を選べます。 基本設定の状態では、XZ平面上にある原点を1つの頂点とする各辺の長さが1の正方形を底面とし、(0,1,0)を頂点とする四角錐が作成されます。 そこからエレメントリスト側の編集で移動や回転を行って空間内に配置します。

円錐

円錐

円錘です。底面設定は円と同様です。それに1頂点を追加して円錘にします。左上のガイドに表示される6点の色が変更できます。 オプションで塗りつぶしの有無と底面および側面の表示/非表示を選べます。 基本設定の状態では、XZ平面上にある原点を中心とする半径1の円を底面とし、(0,1,0)を頂点とする円錐が作成されます。 そこからエレメントリスト側の編集で移動や回転を行って空間内に配置します。なお角度設定が360度の場合、側面はありません。

三角柱

三角柱

三角柱です。底面設定は三角錐(タイプB)と同様です。上面は底面を平行移動して作られます。底面での原点にあたる、上面の1頂点の位置を指定します。 左上のガイドに表示される6点の色が変更できます。オプションで塗りつぶしの有無と上面、底面および側面の表示/非表示を選べます。 基本設定の状態では、XZ平面上にある原点を1つの頂点とする各辺の長さが1の直角2等辺三角形を底面とし、上面の指定頂点を(0,1,0)とする三角柱が作成されます。 そこからエレメントリスト側の編集で移動や回転を行って空間内に配置します。

四角柱

四角柱

四角柱です。底面設定は四角形や四角錘と同様です。上面は底面を平行移動して作られます。底面での原点にあたる、上面の1頂点の位置を指定します。 左上のガイドに表示される8点の色が変更できます。オプションで塗りつぶしの有無と上面、底面および側面の表示/非表示を選べます。 基本設定の状態では、XZ平面上にあり原点を1つの頂点とする各辺の長さが1の正方形を底面とし、上面の指定頂点を(0,1,0)とする四角柱が作成されます。 そこからエレメントリスト側の編集で移動や回転を行って空間内に配置します。

円柱

円柱

円柱です。底面設定は円や円錐と同様です。上面は底面を平行移動して作られます。上面の中心を指定します。 左上のガイドに表示される10点の色が変更できます。オプションで塗りつぶしの有無と上面、底面および側面の表示/非表示を選べます。 基本設定の状態では、XZ平面上にある原点を中心とする半径1の円を底面とし、上部の中心が(0,1,0)とする円柱が作成されます。 そこからエレメントリスト側の編集で移動や回転を行って空間内に配置します。なお角度設定が360度の場合、側面はありません。

半球

半球

半球です。表示範囲の角度と各軸方向の半径を指定します。左上のガイドに表示される6点の色が変更できます。 オプションで塗りつぶしの有無と底面および側面の表示/非表示を選べます。 基本設定の状態ではYが正の部分に、原点を中心とする半径1の半球が作成されます。 そこからエレメントリスト側の編集で移動や回転を行って空間内に配置します。なお角度設定が360度の場合、側面はありません。

球

球です。表示範囲の角度と各軸方向の半径を指定します。左上のガイドに表示される7点の色が変更できます。 オプションで塗りつぶしの有無と底面および側面の表示/非表示を選べます。 基本設定の状態では、原点を中心とする半径1の球が作成されます。 そこからエレメントリスト側の編集で移動や回転を行って空間内に配置します。なお角度設定が360度の場合、側面はありません。

連続線(折れ線)

連続線

各頂点を配列順に結んだ線です。線の太さを変更できます。OpenGLの基本図形であるLINE_STRIPと同じです。 頂点の数は自由に追加および削除、順番の入れ替えが行えます。 基本設定の状態では、(0,0,0)、(1,2,0)を結んだ線が作成されます。 ループをオンにするとリストの最後の頂点と最初の頂点との間も線で結ばれます。

連続三角形

連続三角形

各頂点を配列順に結んでゆき、連続する三点で三角形を作ります。オプションで塗りつぶしの有無を変更できます。 塗りつぶしありの状態ではOpenGLの基本図形であるTRIANGLE_STRIPと同じです。 頂点の数は自由に追加および削除、順番の入れ替えが行えます。 基本設定の状態では、(0,0,0)、(1,2,0)、(2,1,0)の3頂点を結んだ三角形が1個だけ作成されます。 ループをオンにするとリストの最後の頂点と最初の頂点との間が結ばれ、360度の円柱の側面のような閉じた状態になります。

三角扇

三角扇

初めの頂点を扇の中心とし、次以降の連続する二点とで三角形を作りつなげてゆきます。オプションで塗りつぶしの有無を変更できます。 塗りつぶしありの状態ではOpenGLの基本図形であるTRIANGLE_FANと同じです。 頂点の数は自由に追加および削除、順番の入れ替えが行えます。 基本設定の状態では、(0,0,0)、(1,2,0)、(2,1,0)の3頂点を結んだ三角形が1個だけ作成されます。なおこの状態では法線がZ軸のマイナス方向のため、 フロントライトの反射は裏側で起こります。 ループをオンにするとリストの最後の頂点と最初から二番目の頂点との間が結ばれ、底面のない円錐のような閉じた状態になります。


マクロリスト

位置設定

頂点に設定する位置情報をX軸、Y軸、Z軸それぞれについてあらかじめ数値設定したものがリスト表示されます。 バージョン2.0以降では画面左上の色設定をタップすると色設定に表示が切り替わります。

色設定

頂点に設定する色情報を赤、緑、青、アルファ値それぞれについてあらかじめ数値で設定したものがリスト表示されます。 バージョン2.0以降では画面左上の位置設定をタップすると位置設定に表示が切り替わります。


操作方法

通常モード

マクロリスト位置 マクロリスト色

表示項目の切替:左上のボタンのタップ
項目の編集:項目のタップ
マクロリスト編集モード:編集ボタンのタップ

編集モード

マクロリスト位置編集 マクロリスト色編集

項目の編集:項目のタップ
項目の追加:-ボタンのタップ
項目の削除:-ボタンのタップ後、削除ボタンをタップ
項目の移動:-のドラッグ
マクロリスト通常モード:完了ボタンのタップ


ツール

コピー・移動
ダウンロード
アップロード
回転
3D表示設定
混合処理方法
照明
マクロ
リセット


コピー・移動

モード切替スイッチ

コピーの場合にはオン、移動の場合にはオフにします。

対象設定

コピー・移動を行う対象をオブジェクト、パート、エレメントの3種から選択します。

対象物設定

対象を選択します。以前とは選択方式が変わりました。例えばパートの場合では、まずオブジェクトを選択し、次にパートを選択します。

操作先設定

コピー・移動先を選択します。

実行ボタン

コピー・移動を実行します。設定内容が不完全な場合、ボタンに文字が表示されません。


ダウンロード

HTTP(Tiny3DおよびDXF形式)

HTTPダウンロード(Tiny3D) HTTPダウンロード(Tiny3D)
HTTPダウンロード(DXF) HTTPダウンロード(DXF)

以前のサンプルダウンロードとHTTPでのダウンロードを一つに統合し、 さらにHTTPでのDXF形式ファイルのインポート機能も追加しました。 まず作者サイトのTiny3D形式のサンプルダウンロード用のページが表示されます。 リンクからDXF形式のサンプルダウンロードページにも行けるようになっています。 簡易Webブラウザなので、他のページも上にあるアドレスバーにアドレスを入力すれば表示できます。 ブックマークを保存したり呼び出すことも可能です。 ページ内にTiny3D形式またはDXF形式のファイルへのリンクが有る場合、 そのリンクをタップするとダウンロードを行うかを選択するウィンドウが表示されます。 これは作者サイト以外でも機能します。なおDXF形式のファイルのインポートには条件があります。 まず、1メガバイトを越えるファイルはインポートできません。 また、DXFオブジェクトの全てをサポートしているわけではなく、一般的な3Dソフトの出力で用いられる3DFACEオブジェクトと、 LINEおよびPOINTオブジェクトのみを変換します。 詳細については補足情報のDXFのインポートについてを参照してください。

FTP(Tiny3D形式)

FTPダウンロード パスワード入力

指定したディレクトリ、ファイル名情報を使ってTiny3Dオブジェクトファイルをダウンロードします。 ご使用中のコンピューターがMac OS X搭載の場合、簡単な操作でFTPサーバー化ができます。 詳細については補足情報のMacをご使用の方へを参照してください。

操作方法

ブックマークリストから選択:>ボタンのタップ
ブックマークの追加:+ボタンのタップ

FTP(DXF形式)

指定したディレクトリ、ファイル名情報を使ってDXFファイルをダウンロードします。 DXF形式のファイルのインポートには条件があります。 まず、750キロバイトを越えるファイルはインポートできません。 また、DXFオブジェクトの全てをサポートしているわけではなく、一般的な3Dソフトの出力で用いられる3DFACEオブジェクトと、 LINEおよびPOINTオブジェクトのみを変換します。 詳細については補足情報のDXFのインポートについてを参照してください。 ご使用中のコンピューターがMac OS X搭載の場合、簡単な操作でFTPサーバー化ができます。 詳細については補足情報のMacをご使用の方へを参照してください。


アップロード

FTP(Tiny3D形式)

指定したディレクトリに、Tiny3Dオブジェクトファイルをアップロードします。 項目の設定を行いアップロードボタンを押すと、アップロード用のファイルを生成した後、パスワードの入力画面が開きます。 パスワードを入力してOKをタップするとアップロードが始まります。無事にアップロードが完了するとアップロード完了のメッセージが表示されます。 なおパスワードはソフト側には保存されませんので、毎回入力が必要です。 ご使用中のコンピューターがMac OS X搭載の場合、簡単な操作でFTPサーバー化ができます。 詳細については補足情報のMacをご使用の方へを参照してください。

操作方法

ブックマークリストから選択:上の-ボタンのタップ
ブックマークの追加:-ボタンのタップ
アップロードオブジェクトの選択:下の-ボタンのタップ

FTP(DXF形式)

DXF出力

指定したオブジェクトを3D CADの世界で標準的なファイル形式であるDXF形式に変換してアップロードします。 操作方法はTiny3D形式でのアップロードと同じです。バージョン2.0以降では、 出力したデータを利用しやすくするためレイヤーや色情報を付加するようにするなど出力方式を変更しました。 詳細については補足情報のDXFのエクスポートについてを参照してください。 ご使用中のコンピューターがMac OS X搭載の場合、簡単な操作でFTPサーバー化ができます。 詳細については補足情報のMacをご使用の方へを参照してください。

メール添付送信(DXF形式)

Email attached DXF

バージョン3.0では標準のメールの設定を使えるようになりました。 そのため標準のメール設定でSSLを使用するようになっていれば、Tiny3Dからの送信でもSSLを使用して送信します。 まず出力するオブジェクトを選択すると、メール送信用のボタンが反応するようになります。 そこでメール送信ボタンを押すと、DXF形式への変換が行われた後、メール送信用の画面が開きます。 バージョン2.0以降では、出力したデータを利用しやすくするためレイヤーや色情報を付加するようにするなど出力方式を変更しました。 詳細については補足情報のDXFのエクスポートについてを参照してください。


回転

自動回転スイッチ

3Dオブジェクトを自動的に回転させたいときにオンにします。

回転角度

回転角度設定

自動回転の回転量と回転軸のベクトルを設定します。1コマごとに設定した角度で回転するため、 回転軸の周囲に立体を配置するとアニメーションをさせることが出来ます。回転による画面の書き換え回数は最大FPSの値を変更することで変化します。 ただしあくまで最大値を決定するだけなので、フレームレートがもともとその値に達してない場合には制限は有効になりません。


3D表示設定

背景色

背景色設定 ACI選択 ACI選択2

背景の色を変更できます。アルファ値は反映されません。バージョン2.0以降ではACI(AutoCADカラーインデックス)準拠のパレットから選択することもできます。 画面中央右のACI使用をタップすると、ACI選択のパレットが開きます。パレットは上下にスクロールします。 変更したい色をダブルタップするか、右上の完了ボタンを押すとそのインデックスを選択し、元の数値入力画面へと戻ります。 ACIの詳細は補足情報のACI(AutoCADカラーインデックス)についてを参照してください。

ビュー中央座標

3Dビューの中央を変更できます。

操作ガイド表示スイッチ

オンにすると3D表示時に上方へ操作ガイドを表示します。

表示範囲

表示範囲の倍率を指定します。値は初期設定で画面両端におけるX値の絶対値で指定します。 初期値ではリセット時にZ=0の平面でXは-6から6の範囲が、Yは-9から9の範囲が画面に表示されます。


混合処理方法

混合処理設定1 混合処理設定2

Zバッファスイッチ

オンにするとポリゴンが奥行き方向で重なっている場合に、一番手前にある物体だけ表示されます。

追加色設定

各ピクセルの色を計算する際、手前の物体の色をどれだけ混ぜるか選択します。初期値は1で、一番手前のオブジェクトだけが見えます。

現在色設定

各ピクセルの色を計算する際、奥の物体の色をどれだけ混ぜるか選択します。初期値は0で、手前のオブジェクトに遮られるオブジェクトは見えません。

上のスクリーンショットの左側はZバッファオン、追加色1、現在色0です。通常の透明でない物体を表示する場合に適しています。 右側はZバッファオフ、追加色SRC ALPHA、現在色1 - (SRC ALPHA)です。この例では頂点色のアルファ値が128になっているので、現在の色と追加で重ねる色を半分ずつ混合します。 ちなみに現在色と追加色での選択できる項目は以下の通りです。

  • 0
  • 1
  • SRC COLOR
  • 1 - (SRC COLOR)
  • SRC ALPHA
  • 1 - (SRC ALPHA)
  • DST ALPHA
  • 1 - (DST ALPHA)
  • DST COLOR
  • 1 - (DST COLOR)
  • SRC ALPHA SATURATE

照明

ライティングを有効にします。ライトのどれかがオンになっている場合、点、線および連続線以外のエレメントでは、 塗りスイッチがオンになっている状態で色情報が無効になります。

フロントライト

フロントライトオン フロントライトオン_別角度

画面の手前から奥の方向へ光を照射します。物体の表面が視点方向を向いていると、光が反射します。

間接照明

間接照明オン 間接照明オン_別角度

空間を間接照明が照らします。こちらの照明は物体とともに回転するため、この照明のみで物体を照らした場合、 物体のそれぞれの面の明るさは常に一定になります。また、物体からの光の反射は起こりません。

照明2個同時 照明2個同時_別角度

なお、照明は上のスクリーンショットのように2種類を同時にオンにすることも出来ます。


マクロ

マクロリンク

マクロリンク選択 全オブジェクトリンク エレメントリンク

全オブジェクト、オブジェクト、パート、エレメントの各単位で、マクロの一括リンクおよび一括解除が行えます。マクロリンクをタップし、行いたい操作を選んでください。 全オブジェクトを選んだ場合はすぐに、それ以外を選んだ場合は対象をリストから選択しタップすると、どのマクロをリンクさせるかの選択画面が開きます。「位置と色の両方」、「位置のみ」および「色のみ」から選択すると、リンクやリンク解除が行われます。 リンク開始では指定した範囲内に現在リンクがされておらず、マクロリストと名前および数値の全てが一致するものが見つかった場合、その頂点をマクロとリンクさせます。 リンク解除では逆に指定した範囲内のマクロとのリンクを全て解除します。

マクロ削除

位置設定マクロと色設定マクロをそれぞれ全削除できます。エディタ側にあるデータ側の、削除したマクロとのリンクは全て自動的に解除されます。


リセット

リセット

全設定のリセットを行う場合にタップしてください。確認のダイアログが表示されるので、 リセットしたい場合は右側のリセットをタップします。この操作でオブジェクトデータが消えることはありません。


バージョンの確認方法

操作ガイドトップ バージョン確認

バージョン1.5.0以降では、操作ガイドの「はじめに」にある「このソフトについて」をタップして表示されるタイトル部分にバージョンナンバーを表示するようにしています。 それ以前のバージョンはiTunesのアプリケーションでTiny3Dの情報を確認してください。


補足情報

ファイル管理について

バージョン3.0では内部データの格納にCore Dataを用いています。 そのためデータは1ファイルに再度統合されました。


DXFのインポートについて

本ソフトではDXFのオブジェクトのうち、3DFACE、LINE、POINTを認識し、本ソフトのエレメントへと変換します。 3DFACEのうち三角形は三角形のエレメントへ、四角形は三角扇エレメントへ、LINEは線エレメントへPOINTは点エレメントへ変換されます。 カラーコードがある場合はACIとして認識して取り込まれます。また、レイヤー情報が存在する場合、それぞれのレイヤーをパートへと置き換え、 その中に変換した各エレメントを格納します。本ソフトのファイル形式では各頂点に色を割り当てたり、各階層に平行移動や回転、 倍率変更の情報が保存されたりするため、DXFの状態より変換後のほうがファイルサイズが増大します。 そのため1メガバイト以上のファイルは読み込んでも変換を行わないようになっています。 それ以下のサイズのファイルでも、変換後のファイルが10メガバイトを越える場合はデータの保存が出来ません。


DXFへのエクスポートについて

バージョン2.0以降ではオブジェクトの単位は無視して、1個目のパートにカラーコード10を、 それ以降のパートにはそれぞれ20、30、40といった具合に、手前のパートのカラーコードに10を加えたものを割り当てるようにしています。 ちなみに240の次は11を割り当て、次は21を割り当てます。そのようなルールで249まで進み、その後10に戻ります。 ただし、エレメントの1個目の頂点色に付けられている名前がインポートしたデータのように「ACI No.~」といった表記になっている場合には、 その色情報で出力するようになっています。この判定は色の名前のみで行うため、実際の色が別の色でも、名称さえ判定基準を満たせば適応されるようになっています。 また、各パートをレイヤーに変換します。レイヤーの名称は「パート名 - オブジェクト名」となります。


ACI(AutoCADカラーインデックス)について

ACI選択 ACI選択2

ACIは本来1から255までが定義されており、0は無いはずなのですが、カラーコード0で出力される場合も多いようです。 このソフトでは便宜上0を(R128、G128、B128)つまりACI No.8と同じ色として処理しています。 カラーインデックス1から9が代表的な赤、緑、青などといった色で構成され、250から255はグレーの階調色になっています。残りがその他の色です。 カラーインデックス10が1と同じで赤、カラーインデックス50が2と同じで黄色です。この間は10ごとに中間色が入ります。それぞれの1の位は明るさを示し、 0から始まる群(0,2,4,6,8)と1から始まる群(1,3,5,7,9)に分かれます。1から始まるほうは0からの色をいわゆるパステルカラーにしたようなものです。 それぞれの群は値が増えると暗くなります。文章で説明してもわかりにくいですし、インデックスから色を思い浮かべるのは難しいので、 実際の利用法はパレットから選ぶだけということになると思われます。パレットでは最上段から順に0から9、10から19とインデックスが配置されています。 一番下の段が250から255です。10から249までは先ほどのルールがあるため番号順ではなく、左から順に一の位が8,6,4,2,0,1,3,5,7,9という状態で配置されています。 119以上のインデックスはスクロールさせて表示します。各色を1回タップすると色の情報が上に表示されます。 続けて同じ色を選択するか、右上の完了ボタンをタップするとその色情報を選択して元の入力画面に戻ります。


Mac OS Xをご使用の方へ

ご使用のMacがMac OS X搭載機種の場合、同一ネットワーク上にiPhone/iPod touchが接続可能な無線アクセスポイントがあれば、 そのMacを簡単な操作でFTPサーバー化して、データの授受が可能です。

方法

  1. Macのシステム環境設定を開きます。
  2. 共有を開きます。
  3. 左の一覧からファイル共有にチェックを入れます。
  4. 右下のリストで読み書き可能なユーザ名を確認しておきます。
  5. 右下のオプションボタンを押します。
  6. FTPを使用してファイルやフォルダを共有にチェックを入れます。
  7. 項目内にあるftpアドレスをメモしておきます。
  8. Tiny3Dのツールから行いたい操作を選択します。
  9. FTPのアドレスに先ほどメモしたアドレスを入れます。
  10. ユーザー名は先ほど4.で確認した書き込み可能なユーザを入れます。
  11. アップロードの場合は転送したいオブジェクトを選び、ダウンロードの場合はファイル名を入力し、 右上に表示されるアップロードまたはダウンロードのボタンを押します。
  12. パスワード入力画面が出るので、先ほどのユーザに設定されているパスワードを入力します。
  13. 正常に転送できると、確認のメッセージが表示されるのでOKを押します。

これだけの操作でMacのホームフォルダとの間でファイルの授受が行えます。

Copyright© 2009 Konton All rights reserved. - このサイトについて - サイトマップ